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Displaying a raster layer from a netCDF file

Download data from the NOAA ESRL portal:

http://www.esrl.noaa.gov/psd/cgi-
bin/DataAccess.pl?DB_dataset=CDC+Derived+NCEP+Reanalysis+Products+Press
ure+Level&DB variable=Air+Temperature&DB_statistic=Mean&DB tid=40338&
DB_did=37&DB_vid=989

Opening a netCDF file in QGIS
NetCDF format is natively supported in QGIS.
To open a NetCDF file, go to :

Layer->Add Raster Layer
Project Edit View m Settings Plugins Vector Raster Date
D ~— Mew L
o e Embed Layers and Groups...
3 |\ Add vector Layer... Crl+Shift+v
4 (v | . Add Raster Layer... Ctrl+Shift+R
@ Add PostGIS Layers... Ctrl+Shift+D
Vg; /7. Add Spatialite Layer... Crl+Shift+L
' R Add MSSQL Spatial Laver... Ctrl+Shift+mM
e ©, Add Oracle Spatial Layer... Ctrl+Shift+0
'o &%) Add WMS[WMTS Layer... Ctrl+Shift+4
€53 add WCs Layer...
ﬁé '?o' Add WFS Laver...
R 9., Add Delimited Text Layer...
manw <kule

You will be prompted to select which NetCDF file to open, which coordinate
reference system to use (in our case WGS 84), and which variable to import.
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To change the rendering of your data Right-Click on the layer and select
Properties.

_) Zoom to Layer Extent
Zoom ko Best Scale (100%)
Stretch Using Current Extent

|| Show in Overview
. Remove
|| Duplicate
Set Layer CRS
Set Project CRS from Layer
Save As...
Properties
Rename
Copy Style
Add New Group

¥ Expand all

1 Collapse all

%/ Update Drawing Order

You can change the rendering of your data under the Style tab.
* Render type: Singleband gray
* Load button (under Load min/max values)
* (ontrast enhancement: Strech to MinMax

* OK
{} Layer Properties - temperatures | Style _"]5'
‘W Band rendering
Render type | Singleband aray v
| R Ti=nsparency Gray band [Band 001 | v] (Load minfmax values
. Color gradient [Blackto white |V] O Cumulative s - s %o
BB Pyramids count cut
Min |-15705.6 J1 O Min fmax
||- Histogram
Max |-9947.66 [ Wean - (o0 1)
€ standard deviation x K2
IV Metadata Contrast [ siretch to MinMax v
enhancement !
Extent Accuracy
o Full ® Estimate (faster)
Current _ Actual (slower)
w Color rendering
Blending mode | Normal [=)
Brightness ¥ || contrast ¥
ion {3 [ Grayscale | Off l']
Hue || Colorize * Strength ) [100% [5]
W Resampling
\ Zoomed: in [Nearest neighbour [V] out [Nearest neighbour |V] Oversampling | 2.00 [j‘
[ Restore Default Style ] [ Save As Default ] [ Load Style ... ] [ Save Style ... ]
[ OK ] [ Cancel ] [ Apply ] [ Help ]

Your data is now visible in a streched gray version.
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Display a specific time step

Currently QGIS handles each time slice has a single Band. So if you wish to select
a specific time step, you have to select the corresponding band under the Style
tab!

W Band rendering

Render type  Singleband gray =
Gray band Band 001
Color gradient 524 002

. Band 003
Min Band 004
Band 005

Max Band 006
Band 007

Contrast Band 008
enhancement | g.nd ono
Band 010

Another option is to use the NetCDF Browser plugin.

To download and install the NetCDF Browser plugin go to:

Plugins > Manage and Install Plugins...

Search for « netcdf » in the All tab. Select and Install NetCDF Browser.

G Plugins | All (192) 21x|

‘ all Search [net a ]
ry = -
E ] installed gﬂ GHydraulics
*‘"L/ L iznET @R This plugin is experimental
. Not installed \Ehlt LRS
o Multipart Split NetCDF Browser EEN

# Settings

r
=ne|CDF
allows to browse multi-variable and multi-
dimensional netCDF files, requires GDAL >= 1.10

etCDF Browser

© . PpgRoutingLayer

1601 downloads
Tags: netcdf
More info: homepage tracker code repository

Author: Etienne Tourigny

Installed version: 0.3 (in C:\Documents and
Settings\Administratory.qgis2\pythonpluginsinetcdfbrowser)
Available version: 0.3 (in QGIS Official Plugin Repository)

changelog:

0.1 initial version

0.1.1 add missing metadata and project info

0.2 fixes for apivz, other fixes

0.3 parse time values using netcdftime from python-netcdf4 ; use
python api instead of gdalinfo output

Upgrade &l l [Uninstall plugin] [ Reinstall plugin ]

[ Close ] [ Help ]
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Once installed, the NetCDF Browser plugin should appear in your tool bar.

Click on the NetCDF Browser icon to launch it.
You will be asked to select your NetCDF data set.

Select the time slices you wish to display by clicking on Select button next to the
time variable.

{3 NetCDFBrowser 2| x

:nts and Settings/Administrator/Desktop/temperatures.nc

METCDF:"temperatures.nc";

1
1 -
Select
X m

Henderer | aray.

and select the dates you wish to to display.
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| L altnane || 2004-04-01
|%| 2000-01-01 | | 2004-05-01

== |oo | (%] 2000-02-01 | | 2004-06-01
LY @ Y g g G Y %) 2000-03-01 | | 2004-07-01
(% 2000-04-01 | | 2004-08-01
(% 2000-05-01 | | 2004-09-01
(% 2000-06-01 | | 2004-10-01
| | 2000-07-01 | | 2004-11-01
| | 2000-08-01 | | 2004-12-01
| | 2000-09-01 | | 2005-01-01
| | 2000-10-01 | | 2005-02-01
| | 2000-11-01 | | 2005-03-01
| | 2000-12-01 | | 2005-04-01
| | 2001-01-01 | | 2005-05-01
| | 2001-02-01 | | 2005-06-01
| | 2001-03-01 [ | 2005-07-01
DFBrowse | | 2001-04-01 | | 2005-08-01
| | 2001-05-01 | | 2005-09-01
| | 2001-06-01 | | 2005-10-01
Variable ( [l 2001-07-01 [ 2005-11-01
| | 2001-08-01 | | 2005-12-01
| | 2001-09-01 | | 2006-01-01

File [ants and Settings/Administrator /D

time | |2001-10-01 [ | 2006-02-01

| | 2001-11-01 | | 2006-03-01

Dimensions ; | | 2001-12-01 | | 2006-04-01
| | 2002-01-01 | | 2006-05-01

%] multi-selection || 2002-02-01 || 2006-06-01

|1 2002-03-01 | | 2006-07-01

Click on Add Selection and all selected layers will be visible in your Table of
Content.

\aysr Settings Plugins Vector Raster Datsbase Processing Help

DEBRRRHOSLALAHAPPLLLAR QG- H8 BE=-0O 0 1 B
4 B0 R & s> 0 /= F 8RB OH

B

[

“

S»R8889N

Layers | Browser

5] oot | Zaet Tce [seets.ro o[ render e (@] o]

Classifying a NetCDF layer
If you wish to classify one layer with a color ramp, you have to :
1. Right-click on the selected layer > Properties
2. Under Style tab > Render type : select Singleband pseudocolor
3. Click on the Classify button (do not forget to invert the color ramp)
4. OK
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{§ Layer Properties - temperatures.nc_time=2000-06-01_band=006 | Style _"_Iﬁl
‘W Band rendering z
e
’ Style ¥Pe | Singleband pseudocolor
| ] TSI Band Band 001 n ~Generate new color map
2 ol nerpolation e || v
B3 Pyramids
E] @ Mode | Continuous v Classes |5 [a
IR ristogram Min | -15705.6 | Max | -9947.66 |
= Value Color Label
f| Metadata -15705.600000 H -15705.600000 [ Classify
-14266.115000 -14266.115000
-12626,630000 -12626.630000 Min { max origin
-11387.145000 -11387.145000
-9947.660000 [N -9947.660000 Estimated cumulative cut of Full extent.
~Load minfmax values
Cumulative [~ =]
o St (2 (2]~ [s00 3] %
) Min | max
- Mean +- =
" standard deviation x Lo (S
Extent Accuracy m
@ Full ® Estimate (Faster)
) Current ) Actual (slower)
Cae e
lv Color rendering ] @
[ Restore Default Style ] [ Save As Default ] [ Load Style ... ] [ Save Style ... ]

| ok || cancel || apply || Hep

Your layer is now classified with 5 classe and a color ramp.

Exporting a specific time step in GeoTiff
You can export in GeoTiff a specific time step.
1. Right-Click on the Selected layer
2. SaveAs...
3. You will be prompted with the following window
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{3 Save raster layer as... Jied b3

Output mode | ' Rawdata @ Renderedimage

Format | GTiff || [ Create WRT
Save as [C:IDocuments and Settings/Administrator/Deskkopftemperature20000101 . tif ] Browse...
CRS | Layer (WGS 84, EPSG:4326) |+]| change...
W Extent {current: layer) Z
North [91.25 ]
West [-1.25 ] East |358.75
South |-91.25 J
[ Layer extent } [ Map view extent ]
W Resolution {current: layer) m
® Horizontal [2.5 ] Vertical [2.5 ] Layer resolution
_ Columns [144 ] Rows [73 ] Layer size
w | | Create Options
Profile [Default IV]
Name Yalue | D
g
’ OK l [ Cancel ]

You can export either the Raw data (complete data set) or the Rendered Image
(only the selected one with the desired classification). You can also, create subset

by changing extent values, and change also the resolution of your data set.

4. Keep default values and select Rendered image.
5. OK > your layer is now saved in GeoTiff.

Displaying information on the NetCDF file
If you wish to display information on your data set you have two options.

1. Get Summary Information on your dataset :
Right-click on the selected layer > Properties > General

You have basic information such as the name of the layer, source, CRS.

)5 | General 2] x|
Layer nare | temperatures.nc_time=2000-05-01_band=005 | displayed as | temperatures.nc_tine=2000-05-01_band=005 |
Layer source | NETCOF:"C; 2 J
Colurns: 144 Rows: 73 No-Data Value: 32766
W Coordnate reference system
[ EPsG:4326 - Was 84 ][ specy..
v (] visbity
Maximum P [ =) Minimum o 5
e o [0 (exclusve) &~ [1:100,000,000
( Current ] ( Cunent |
Thumbnal Legend | [ Paette

RestoreDefout Style | | Save As Default J Load Stye .. J ( Save style .. |

o J[ cocel || ooy | [ mep |
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2. Under the Metadata tab > Properties, you can access more detailed
information (that can be also displayed using Raster > Miscellaneous >
Information)

{3 Layer Properties - temperatures.nc_time=2000-05-01_band=005 | Metadata 3 _"Jﬁ

%

_ General ‘W Description

Title ( ]
N style
I.‘ ansparency g
ﬁ Pyramids Keyword list

[ ]
( | Format | B

l Histogram

W Attribution

Title | ]

url [ ]

W Metadatalrl
url [ ]

Type [ 1V] Format [ |v]

W Properties

Driver -
GDAL provider

netCOF
Network Common Data Format

Dataset Description
MNETCDF:"C:/Documents and Settings/Administrator/Desktop/temperatures.nc:
air#actual_range={-45.379997,43,169998} E
Restore Default Style | | Save As Default J Load Style ... J Save Style .. J
[ OK l [ Cancel ] [ Apply ] [ Help ]

21 x|
Input file [temperatures.nc_time=2000-06-01_band=006 tj

Raster info

Driver: netCDF/Metwork Common Data Format -
Files: none associated

Size is 144, 73

Coordinate System is ™' -

Origin = (-1,250000000000000,91.,250000000000000)
i ize = 7 SNNNNNNNNNNNNAN -2 SNNNNNNNNNNNNNMY

4 |4|)|

| Suppress GCP printing

|| Suppress metadata printing

gdalinfo "NETCDF:\"C:/Documents and J

Settings/Administrator/Desktop/temperatures.nci:

oK Close ] [ Help

10
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Creating a temperature table at a specific location

So far it is not possible to extract a temperature table at a specific location.
However, there are two plugins (Value tool, gdal2xyz) that can be useful to
retrieve temperatures based on location.

Value tool
Load the complete NetCDF data set (Layer > Add Raster Layer...)

Install and launch the Value tool plugin. This is a docket widget that allows you
to explore values layers as table or graphs.

Click on a specific location (you have the coordinate of the point on the bottom of
the plugin window) and you can display values as a table or as a graph.

(x N ) Value Tool Q06 Value Tool
v/ Enable |V Enable
Graph | Options | | Table m Options |
[ |Decimals 2 |[%] Ymin | | Ymax
Layer Value
1 gmporatires | .12427.0 00
2 [Pmperalires | .12334.0 100
3 [omperalres | .12581.0 00§ ]
5  lemperalures | .12156.0

20 40 60 80100120140160

Coordinate: (115.551262, 42.629338) Coordinate: (115.551262, 42.629338)

You can select the table (Ctrl + A) and copy/paste the value in an Excel table.

gdal2xyz
The second option is to use the gdal2xyz tool that is available in Processing >
Toolbox, under GDAL/OGR > [GDAL] Conversion

Q06 Processing Toolbox

Search

» Recently used algorithms
v &» GDAL/OGR [32 geoalgorithms]
» [GDAL] Analysis
v [GDAL] Conversion
i gdal2xyz
- PCTto RGB
2 Polygonize (raster to vector)
“ Rasterize (vector to raster)
“_ RGBtoPCT
¥, Translate (convert format)
[GDAL] Extraction
[GDAL] Miscellaneous
[GDAL] Projections
[OGR] Conversion
[OGR] Miscellaneous
» [E GeoServer/PostGIS tools [8 geoalgo...
» ‘y GRASS commands [157 geoalgorith...
M Aodolo (A cooolanbbhesal

| Advanced interface A

vyVVvVvYyYYVYY

11
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You have to select a time slice (e.g., dand number) and give a name to the Output
file (in csv format).

gdal2xyz
GEELEESM Log | Help |

Input layer
| temperatures [EPSG:4326) s - |

Band number
11 G-
Output file

\/Users/greg/Desktopltempera(ureB1 .csv \| |

(V] Open output file after running algorithm

[ 1
| Run | Cancel | Close |

Click Run

Each line of the CSV file correspond to XY coordinates and the value of the pixel.

0.000 90.000 -15674
2.500 90.000 -15674
5.000 90.000 -15674
7.500 90.000 -15674
10.000 S0.000 -15674
12,500 S0.000 -15674
15.000 S0.000 -15674
17.500 S0.000 -15674
20.000 90.000 -15674
22,500 90.000 -15674
25.000 90.000 -15674
27.500 90.000 -15674
30.000 90.000 -15674

7 NN oan Nnn -1TERTA

12
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Finding temperature difference between two time steps

Use the NetCDF Browser to extract two layers at different date.

Then go to: Raster > Raster Calculator

Double click on your first layer, then click on

o«

, and finally double-click on the

second layer. The expression should look like:
"temperatures.nc_time=2000-01-01_band=001@1" -
"temperatures.nc_time=2014-01-01_band=169@169"

Give an Output layer name: tempDifferences.tif

OK

{# Raster calculator

~Raster bands

"temperatures.nc_time=2014-01-01_band=169@1 B
"temperatures.nc_time=2014-01-01_band=169@1
"temperatures.nc_time=2014-01-01_band=169@1

"temperatures.nc_time=2014-01-01_band=169@1

~Result layer

Qutput layer

Current layer extent

[inistrator.fDesktopj‘tempDiFFerences }

"temperatures.nc_time=2014-01-01:band=169@1

"temperatures.nc_time=2014-01-01_band=169@1 xmin | -1.25000 |$] xMax |358.75000
"temperatures.nc_time=2014-01-01_band=169@1

“temperatures.nc_time=2014-01-01_band=169@1 ¥min | -91.25000 ‘2| ¥max 91.25000
"temperatures.nc_time=2014-01-01_band=169@1

"temperatures.nc_time=2014-01-01_band=169@1 Columns [144 }%] Rows [73
"temperatures.nc_time=2014-01-01_band=169@1

"temperatures.nc_time=2014-01-01_band=169@1 - Qutput Format [GeoTIFF ] v]
(<] i | [a]» 1% Add result to project

W Operators

L J Jem Jw I ) e ) o]
L J v JCw Jlwm Jm e J ]
< JL > JlL = J[ = J{ > J{ aw J[ x |

~Raster calculator expression

"temperatures.nc_time=2000-01-01_band=001@1" - "temperatures.nc_time=2014-01-01_band=169@169"

Expression valid

o

] [ Cancel

With a color ramp (5 class, inverted), the result will look like:

13
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You can do the same operation using the Graphical Modeler (Processing >

Graphical modeler).

Inputs: create two Raster Layer and give them a name

Algorithms: search for mapcalculator and select the GRASS command

r.mapcalculator

Double click on it > fill correctly the information (raster layers, Formula)

Run the model

{4 Processing modeler

BEE) =3

—Ioix]

mapc a [[Entev model name here]

[ tenter group name here]

By GRASS commands
EJ-Raster (r*)
Q r.mapcalculator - Calculate new raster m...

|4}-I1

i

‘<% In

4 ‘ ¥ rmapcalculator - Calculat...:y" temperatureDiffer

g Out He—
x
Parameters | Log | Help |
I
s vz b g
3
( e 01-01_band=169 [EP5G:4326] [l J
temperatureDiffer
[[Save to temporary file] ][ o ]
[%] Open output File after running algorithm
Inputs Algorithms.
0% |

Run

I[ Close: ][ Cancel I

14
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Creating a temporal animation

You have two options to create animations
1. Using the “Loop Visible Layers” plugin
2. Using the “Time Manager plugin

Install the two plugins

Loop Visible Layers
Use the NetCDF Browser to extract some layers.

Open the Loop Visible Layers plugin

Q6 Loop Visible Layers

Select Group | <Visible Layers> -

! (D)
Controls D )

v)
v

Loop Delay 1.0 (sec.)

Enable render caching to improve performance

Click on the Play control and you will see your different displayed in a loop.

Unfortunately you cannot save your animation.

Time Manager plugin

Time Manager adds time controls to QGIS. Using these time controls, you can
animate vector features based on a time attribute. There is also an experimental
raster layer support. You can create animations directly in the map window and
export image series.

Moreover there are several bugs related to QGIS 2.x

You can have a look to this video, to understand how Time Manager currently
handles NetCDF data:
https://www.youtube.com/watch?v=QdijfgghsPI
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